import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<han>\\p{Han}+)\\b|\\b(?<alpha>[a-zA-Z0-9\\{\\}']+)\\b|(?<other>[^\\p{Han}A-Za-z0-9\\s]+)";
final String string = "Many cats{1}, several rats{2}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}