$re = '~\b(?<han>\p{Han}+)\b|\b(?<alpha>[a-zA-Z0-9{}\']+)\b|(?<other>[^\p{Han}A-Za-z0-9\s]+)~su';
$str = 'Many cats{1}, several rats{2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);