re = /\b(?<han>\p{Han}+)\b|\b(?<alpha>[a-zA-Z0-9{}']+)\b|(?<other>[^\p{Han}A-Za-z0-9\s]+)/
str = 'Many cats{1}, several rats{2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end