# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https:\\/\\/s3.amazonaws.com\\/(.?[^\\/]*)\\/(.*)/[\1] | [\2]/gm;t' <<< "https://s3.amazonaws.com/jge-catalog-lake/guanaTest/Pet_Resource_Template.gdb.zip
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/DKU_TSHIRTS/orders_copy/out-s0.csv.gz
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/Approved_Data/Pet_Sed_Thick/Pet_Sediment_Thickness_Through_Time_P2V2_Resampled.tif.zip
"