import re
regex = re.compile(r"https:\/\/s3.amazonaws.com\/(.?[^\/]*)\/(.*)", flags=re.MULTILINE)
test_str = ("https://s3.amazonaws.com/jge-catalog-lake/guanaTest/Pet_Resource_Template.gdb.zip\n"
"https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/DKU_TSHIRTS/orders_copy/out-s0.csv.gz\n"
"https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/Approved_Data/Pet_Sed_Thick/Pet_Sediment_Thickness_Through_Time_P2V2_Resampled.tif.zip\n")
subst = "[\\1] | [\\2]"
result = regex.sub(subst, test_str)
if result:
print(result)