package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/s3.amazonaws.com\/(.?[^\/]*)\/(.*)`)
var str = `https://s3.amazonaws.com/jge-catalog-lake/guanaTest/Pet_Resource_Template.gdb.zip
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/DKU_TSHIRTS/orders_copy/out-s0.csv.gz
https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/Approved_Data/Pet_Sed_Thick/Pet_Sediment_Thickness_Through_Time_P2V2_Resampled.tif.zip
`
var substitution = "[\1] | [\2]"
fmt.Println(re.ReplaceAllString(str, substitution))
}