#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https:\/\/s3.amazonaws.com\/(.?[^\/]*)\/(.*)"
Local $sString = "https://s3.amazonaws.com/jge-catalog-lake/guanaTest/Pet_Resource_Template.gdb.zip" & @CRLF & _
"https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/DKU_TSHIRTS/orders_copy/out-s0.csv.gz" & @CRLF & _
"https://s3.amazonaws.com/jge-data-platform-primary-automation-prod/Approved_Data/Pet_Sed_Thick/Pet_Sediment_Thickness_Through_Time_P2V2_Resampled.tif.zip" & @CRLF & _
""
Local $sSubst = "[\1] | [\2]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)