# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\((?:[^()]++|(?-1))*\))(*SKIP)(*F)|[()]//gm;t' <<< "Book (Pg 1)
Website) Online)
Journal: 2018)
Book1 (pg 2) book 3 (pg4) something)
Book1 ((pg 2) (b(o(o))k) 3) (pg4) something)
"