import Foundation
let pattern = #"(\((?:[^()]++|(?-1))*\))(*SKIP)(*F)|[()]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Book (Pg 1)
Website) Online)
Journal: 2018)
Book1 (pg 2) book 3 (pg4) something)
Book1 ((pg 2) (b(o(o))k) 3) (pg4) something)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)