// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\((?:[^()]++|(?-1))*\))(*SKIP)(*F)|[()]").unwrap();
let string = "Book (Pg 1)
Website) Online)
Journal: 2018)
Book1 (pg 2) book 3 (pg4) something)
Book1 ((pg 2) (b(o(o))k) 3) (pg4) something)
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}