$re = '/(\((?:[^()]++|(?-1))*\))(*SKIP)(*F)|[()]/m';
$str = 'Book (Pg 1)
Website) Online)
Journal: 2018)
Book1 (pg 2) book 3 (pg4) something)
Book1 ((pg 2) (b(o(o))k) 3) (pg4) something)
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;