use strict;
my $str = 'Book (Pg 1)
Website) Online)
Journal: 2018)
Book1 (pg 2) book 3 (pg4) something)
Book1 ((pg 2) (b(o(o))k) 3) (pg4) something)
';
my $regex = qr/(\((?:[^()]++|(?-1))*\))(*SKIP)(*F)|[()]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";