# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^| )3 [дД]($|[ .,!?:;])/$13д$2/gm;t' <<< "Могут быть строки вида
3 д панель
панель 3 д
панель 3 Д
плитка 3 д. (может быть любой знак препинания)
ул. Степана Разина 23 д 3 кв 3 (23 д Не должно замениться)
Если будет 223 д или 223 дом не должно заменяться.
Нужно что бы в строке \"3 д\" заменилось на \"3д\" ли \"3д.\"
может быть любой знак препинания после \"д\".
Так же может быть большая \"Д\"
Помогите пожалуйста в регулярках не силен."