package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^| )3 [дД]($|[ .,!?:;])`)
var str = `Могут быть строки вида
3 д панель
панель 3 д
панель 3 Д
плитка 3 д. (может быть любой знак препинания)
ул. Степана Разина 23 д 3 кв 3 (23 д Не должно замениться)
Если будет 223 д или 223 дом не должно заменяться.
Нужно что бы в строке "3 д" заменилось на "3д" ли "3д."
может быть любой знак препинания после "д".
Так же может быть большая "Д"
Помогите пожалуйста в регулярках не силен.`
var substitution = "$13д$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}