#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^| )3 [дД]($|[ .,!?:;])"
Local $sString = "Могут быть строки вида" & @CRLF & _
"3 д панель" & @CRLF & _
"панель 3 д" & @CRLF & _
"панель 3 Д" & @CRLF & _
"плитка 3 д. (может быть любой знак препинания)" & @CRLF & _
"ул. Степана Разина 23 д 3 кв 3 (23 д Не должно замениться)" & @CRLF & _
"Если будет 223 д или 223 дом не должно заменяться." & @CRLF & _
"" & @CRLF & _
"Нужно что бы в строке "3 д" заменилось на "3д" ли "3д."" & @CRLF & _
"может быть любой знак препинания после "д"." & @CRLF & _
"Так же может быть большая "Д"" & @CRLF & _
"" & @CRLF & _
"Помогите пожалуйста в регулярках не силен."
Local $sSubst = "$13д$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)