import Foundation
let pattern = #"(^| )3 [дД]($|[ .,!?:;])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Могут быть строки вида
3 д панель
панель 3 д
панель 3 Д
плитка 3 д. (может быть любой знак препинания)
ул. Степана Разина 23 д 3 кв 3 (23 д Не должно замениться)
Если будет 223 д или 223 дом не должно заменяться.
Нужно что бы в строке "3 д" заменилось на "3д" ли "3д."
может быть любой знак препинания после "д".
Так же может быть большая "Д"
Помогите пожалуйста в регулярках не силен.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$13д$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)