use strict;
my $str = 'Могут быть строки вида
3 д панель
панель 3 д
панель 3 Д
плитка 3 д. (может быть любой знак препинания)
ул. Степана Разина 23 д 3 кв 3 (23 д Не должно замениться)
Если будет 223 д или 223 дом не должно заменяться.
Нужно что бы в строке "3 д" заменилось на "3д" ли "3д."
может быть любой знак препинания после "д".
Так же может быть большая "Д"
Помогите пожалуйста в регулярках не силен.';
my $regex = qr/(^| )3 [дД]($|[ .,!?:;])/mp;
my $subst = '$13д$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";