#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-([^-\n]+)(?:-|$)"
Local $sString = "tumPar-PredCorr" & @CRLF & _
"lung-Med-Pred" & @CRLF & _
"liver-t1flair-FromMed" & @CRLF & _
"kidney-t1ce-Pred" & @CRLF & _
"tumMed-Pred"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")