re = /-([^-\n]+)(?:-|$)/m
str = 'tumPar-PredCorr
lung-Med-Pred
liver-t1flair-FromMed
kidney-t1ce-Pred
tumMed-Pred'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end