$re = '/-([^-\n]+)(?:-|$)/m';
$str = 'tumPar-PredCorr
lung-Med-Pred
liver-t1flair-FromMed
kidney-t1ce-Pred
tumMed-Pred';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);