using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-([^-\n]+)(?:-|$)";
string input = @"tumPar-PredCorr
lung-Med-Pred
liver-t1flair-FromMed
kidney-t1ce-Pred
tumMed-Pred";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}