#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/gsd\.zgjx\.zwa\.com(?!\/gsd\/translation)"
Local $sString = "https://gsd.zgjx.zwa.com" & @CRLF & _
"https://gsd.zgjx.zwa.com/" & @CRLF & _
"https://gsd.zgjx.zwa.com/gsd/translation/" & @CRLF & _
"https://gsd.zgjx.zwa.com/1/2/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")