using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/gsd\.zgjx\.zwa\.com(?!\/gsd\/translation)";
string input = @"https://gsd.zgjx.zwa.com
https://gsd.zgjx.zwa.com/
https://gsd.zgjx.zwa.com/gsd/translation/
https://gsd.zgjx.zwa.com/1/2/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}