$re = '/^https:\/\/gsd\.zgjx\.zwa\.com(?!\/gsd\/translation)/m';
$str = 'https://gsd.zgjx.zwa.com
https://gsd.zgjx.zwa.com/
https://gsd.zgjx.zwa.com/gsd/translation/
https://gsd.zgjx.zwa.com/1/2/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);