re = /^https:\/\/gsd\.zgjx\.zwa\.com(?!\/gsd\/translation)/m
str = 'https://gsd.zgjx.zwa.com
https://gsd.zgjx.zwa.com/
https://gsd.zgjx.zwa.com/gsd/translation/
https://gsd.zgjx.zwa.com/1/2/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end