const regex = /^https:\/\/gsd\.zgjx\.zwa\.com(?!\/gsd\/translation)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/gsd\\.zgjx\\.zwa\\.com(?!\\\/gsd\\\/translation)', 'gm')
const str = `https://gsd.zgjx.zwa.com
https://gsd.zgjx.zwa.com/
https://gsd.zgjx.zwa.com/gsd/translation/
https://gsd.zgjx.zwa.com/1/2/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}