#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([1-9]|1[0-9]|2[0-4])(\.[0-9]{1,2})?|25|25\.0|25\.00)$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"5" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"20" & @CRLF & _
"24" & @CRLF & _
"25" & @CRLF & _
"25.0" & @CRLF & _
"25.00" & @CRLF & _
"25.01" & @CRLF & _
"25.99" & @CRLF & _
"26" & @CRLF & _
"30" & @CRLF & _
"40" & @CRLF & _
"100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")