$re = '/^(([1-9]|1[0-9]|2[0-4])(\.[0-9]{1,2})?|25|25\.0|25\.00)$/m';
$str = '0
1
2
5
10
15
20
24
25
25.0
25.00
25.01
25.99
26
30
40
100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);