const regex = /^(([1-9]|1[0-9]|2[0-4])(\.[0-9]{1,2})?|25|25\.0|25\.00)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([1-9]|1[0-9]|2[0-4])(\\.[0-9]{1,2})?|25|25\\.0|25\\.00)$', 'gm')
const str = `0
1
2
5
10
15
20
24
25
25.0
25.00
25.01
25.99
26
30
40
100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}