import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([1-9]|1[0-9]|2[0-4])(\\.[0-9]{1,2})?|25|25\\.0|25\\.00)$";
final String string = "0\n"
+ "1\n"
+ "2\n"
+ "5\n"
+ "10\n"
+ "15\n"
+ "20\n"
+ "24\n"
+ "25\n"
+ "25.0\n"
+ "25.00\n"
+ "25.01\n"
+ "25.99\n"
+ "26\n"
+ "30\n"
+ "40\n"
+ "100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}