package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([1-9]|1[0-9]|2[0-4])(\.[0-9]{1,2})?|25|25\.0|25\.00)$`)
var str = `0
1
2
5
10
15
20
24
25
25.0
25.00
25.01
25.99
26
30
40
100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}