$re = '/\[caption([^\]]+)align="([^"]+)"\s+width="(\d+)"\](\s*\<img[^>]+>)\s*(.*?)\s*\[\/caption\]/';
$str = '[caption id="attachment_666" align="alignleft" width="316"]
<img class="wp-image-92692" src="img" width="316" alt="fitbit-yoga-lady.png" height="210">
text
[/caption]';
$subst = "<div\1style=\"width: \3px\" class=\"wp-caption \2\">\4\n <p class=\"caption\">\5</p>\n</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;