// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\[caption([^\]]+)align="([^"]+)"\s+width="(\d+)"\](\s*\<img[^>]+>)\s*(.*?)\s*\[\/caption\]"#).unwrap();
let string = "[caption id=\"attachment_666\" align=\"alignleft\" width=\"316\"]
<img class=\"wp-image-92692\" src=\"img\" width=\"316\" alt=\"fitbit-yoga-lady.png\" height=\"210\">
text
[/caption]";
let substitution = "<div\\1style=\"width: \\3px\" class=\"wp-caption \\2\">\\4\\n <p class=\"caption\">\\5</p>\\n</div>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}