import re
regex = re.compile(r"\[caption([^\]]+)align=\"([^\"]+)\"\s+width=\"(\d+)\"\](\s*\<img[^>]+>)\s*(.*?)\s*\[\/caption\]")
test_str = ("[caption id=\"attachment_666\" align=\"alignleft\" width=\"316\"]\n"
" <img class=\"wp-image-92692\" src=\"img\" width=\"316\" alt=\"fitbit-yoga-lady.png\" height=\"210\"> \n"
" text\n"
"[/caption]")
subst = "<div\\1style=\"width: \\3px\" class=\"wp-caption \\2\">\\4\\n <p class=\"caption\">\\5</p>\\n</div>"
result = regex.sub(subst, test_str)
if result:
print(result)