using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)error[\s]?syncing[\s]?pod$";
string input = @"ERROR asdas
Error sdas error
error
asdw
error syncing pod
syncing pod
ERROR syncIng pod
Error syncing pod
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}