re = /^(?i)error[\s]?syncing[\s]?pod$/m
str = 'ERROR asdas
Error sdas error
error
asdw
error syncing pod
syncing pod
ERROR syncIng pod
Error syncing pod
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end