const regex = /^(?i)error[\s]?syncing[\s]?pod$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)error[\\s]?syncing[\\s]?pod$', 'gm')
const str = `ERROR asdas
Error sdas error
error
asdw
error syncing pod
syncing pod
ERROR syncIng pod
Error syncing pod
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}