import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)error[\\s]?syncing[\\s]?pod$";
final String string = "ERROR asdas\n"
+ "Error sdas error\n"
+ "error\n"
+ "asdw \n"
+ "error syncing pod\n"
+ "syncing pod\n"
+ "ERROR syncIng pod\n"
+ "Error syncing pod\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}