$re = '/^(?i)error[\s]?syncing[\s]?pod$/m';
$str = 'ERROR asdas
Error sdas error
error
asdw
error syncing pod
syncing pod
ERROR syncIng pod
Error syncing pod
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);