import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Order[0-9])(?!.*\\1)";
final String string = "<ctx>\n"
+ " <PostCode>XXXXXX</PostCode>\n"
+ " <Title1>Mr</Title1>\n"
+ " <Name>John</Name>\n"
+ " <Order1>£100.00</Order1>\n"
+ " <Order2>£100.01</Order2>\n"
+ " <Order3>£100.01</Order3>\n"
+ " <Order4>£100.01</Order4>\n"
+ " <Order5>£100.01</Order5>\n"
+ " <Order6>£100.01</Order6>\n"
+ " <Order7>£100.01</Order7>\n"
+ " <Order8>£100.01</Order8>\n"
+ " <Order9>£100.01</Order9>\n"
+ " <Order10>£100.01</Order10>\n"
+ " <Order11>£100.01</Order11>\n"
+ " <Order50>£100.01</Order50>\n"
+ " <Date>10/10/2010</Date>\n"
+ "</ctx>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}