import re
regex = re.compile(r"(Order[0-9])(?!.*\1)")
test_str = ("<ctx>\n"
" <PostCode>XXXXXX</PostCode>\n"
" <Title1>Mr</Title1>\n"
" <Name>John</Name>\n"
" <Order1>£100.00</Order1>\n"
" <Order2>£100.01</Order2>\n"
" <Order3>£100.01</Order3>\n"
" <Order4>£100.01</Order4>\n"
" <Order5>£100.01</Order5>\n"
" <Order6>£100.01</Order6>\n"
" <Order7>£100.01</Order7>\n"
" <Order8>£100.01</Order8>\n"
" <Order9>£100.01</Order9>\n"
" <Order10>£100.01</Order10>\n"
" <Order11>£100.01</Order11>\n"
" <Order50>£100.01</Order50>\n"
" <Date>10/10/2010</Date>\n"
"</ctx>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")