$re = '/(Order[0-9])(?!.*\1)/';
$str = '<ctx>
<PostCode>XXXXXX</PostCode>
<Title1>Mr</Title1>
<Name>John</Name>
<Order1>£100.00</Order1>
<Order2>£100.01</Order2>
<Order3>£100.01</Order3>
<Order4>£100.01</Order4>
<Order5>£100.01</Order5>
<Order6>£100.01</Order6>
<Order7>£100.01</Order7>
<Order8>£100.01</Order8>
<Order9>£100.01</Order9>
<Order10>£100.01</Order10>
<Order11>£100.01</Order11>
<Order50>£100.01</Order50>
<Date>10/10/2010</Date>
</ctx>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);