# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\d+\h*x\h*)?\K\d+//gm;t' <<< "4 x 120glgt
120glgt"