use strict;
my $str = '4 x 120glgt
120glgt';
my $regex = qr/^(?:\d+\h*x\h*)?\K\d+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";