$re = '/^(?:\d+\h*x\h*)?\K\d+/m';
$str = '4 x 120glgt
120glgt';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;