#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-2]{1}[0-4]{1}:[0-5]{1}[0-9]{1}(?::[0-5]{1}[0-9]{1})*$"
Local $sString = "" & @CRLF & _
"Good" & @CRLF & _
"24:58:59" & @CRLF & _
"00:00:00" & @CRLF & _
"24:00:00" & @CRLF & _
"24:00" & @CRLF & _
"01:03:04" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"bad" & @CRLF & _
"1:23:34" & @CRLF & _
"12:00:60" & @CRLF & _
"25:00:00" & @CRLF & _
"12:60:23" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")