re = /^[0-2]{1}[0-4]{1}:[0-5]{1}[0-9]{1}(?::[0-5]{1}[0-9]{1})*$/m
str = '
Good
24:58:59
00:00:00
24:00:00
24:00
01:03:04
bad
1:23:34
12:00:60
25:00:00
12:60:23
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end