import Foundation
let pattern = #"^[0-2]{1}[0-4]{1}:[0-5]{1}[0-9]{1}(?::[0-5]{1}[0-9]{1})*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Good
24:58:59
00:00:00
24:00:00
24:00
01:03:04
bad
1:23:34
12:00:60
25:00:00
12:60:23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)