use strict;
my $str = '
Good
24:58:59
00:00:00
24:00:00
24:00
01:03:04
bad
1:23:34
12:00:60
25:00:00
12:60:23
';
my $regex = qr/^[0-2]{1}[0-4]{1}:[0-5]{1}[0-9]{1}(?::[0-5]{1}[0-9]{1})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}