using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-2]{1}[0-4]{1}:[0-5]{1}[0-9]{1}(?::[0-5]{1}[0-9]{1})*$";
string input = @"
Good
24:58:59
00:00:00
24:00:00
24:00
01:03:04
bad
1:23:34
12:00:60
25:00:00
12:60:23
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}